Archiwa kategorii: Network

OLT Huawei – syslog i monit

OLT Huawei’a potrafi wysyłać logi poprzez syslog po UDP.

Aby włączyć zdalne słuchanie sysloga w Linuksie w rsyslog należy odremować linie w /etc/rsyslog.conf:
$ModLoad imudp
$UDPServerRun 514

Dobrze dodać aby log z OLT szedł do innego pliku, robi się to dodając do /etc/rsyslog.conf na początku reguł linie:

if $fromhost-ip startswith ‚10.11.x.’ then /var/log/olt.log
& ~

(gdzie 10.11.x to podsieć w której jest OLT. Ta druga linia oznacza, że ma już pozostałych reguł nie przechodzić, i nie zapisywać ponownie)

W OLT ustawiamy:
syslog enable alarm-event
loghost add 10.11.x.x log_server
loghost activate ip 10.11.x.x

gdzie 10.11.x.x to serwer rsyslogd

Teraz możemy skonfigurować monit, który będzie nas informował o problemach. W /etc/init.d/monitrc ustawiamy:

set mailserver localhost
set mail-format { from: [email protected]
subject: $SERVICE $EVENT at $DATE
message: Monit $ACTION $SERVICE at $DATE on $HOST: $DESCRIPTION.
Yours sincerely,
monita
check file olt.log with path /var/log/olt.log
if match „FAULT”
then alert
if match „RECOV”
then alert

Można bardziej szczegółowo ustawić informowanie, np.
if match „fiber is broken” lub „LOSi/LOBi” i będziemy dostawać emaile w przypadku prawdopodobnego ucięcia światłowodów do klientów, a o mniej istotnych informacjach nie.

mikrotik jako PIM router do telewizji (multicast)

/interface vlan
add interface=ether1 name=internet vlan-id=13
add interface=ether1 name=stb vlan-id=401
add interface=ether1 name=transmisja vlan-id=3700
/ip address
add address=192.168.x.50/29 interface=transmisja network=192.168.x.48
add address=172.16.5.2/24 interface=internet network=172.16.5.0
add address=10.1.1.1/24 interface=stb network=10.1.1.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall nat
add action=src-nat chain=srcnat out-interface=internet src-address=10.1.1.0/24 to-addresses=172.16.5.2
/ip route
add distance=1 gateway=172.16.5.1
add distance=1 dst-address=10.10.1.x/32 gateway=192.168.x.49
add distance=1 dst-address=10.100.y.0/24 gateway=192.168.x.49
add distance=1 dst-address=192.168.176.0/22 gateway=192.168.x.49
/routing pim
set switch-to-spt-interval=30s
/routing pim interface
add interface=stb
add interface=transmisja
/routing pim rp
add address=10.100.110.z

Nie konfiguruję dhcp, gdyż adresy rozdaje linux 10.1.1.2 w vlanie 401.

Dlaczego nie cisco? Docelowo tak będzie. Mikrotik bierze mniej prądu, na razie wystarcza.
Chciałem użyć do tego OLT Huawei MA5683T, ale wydaje się, że nie ma w nim PIM SM.

Podstawowa konfiguracja OLT Huawei MA5683T (SCUN)

defaultowy IP 10.11.104.2 login: root hasło: admin
(backspace działa po wciśnięciu CTRL-H)

#display board 0
————————————————————————-
SlotID BoardName Status SubType0 SubType1 Online/Offline
————————————————————————-
0 H805GPFD Normal
1
2
3
4
5
6 H802SCUN Active_normal
7 H802SCUN Standby_normal
8 H801GICF Normal
9 H801X2CS Normal
10
11
12
————————————————————————-

Jeśli któraś z kart nie ma statusu Normal, trzeba ją dodać, np.
config
board add board add 0/0 H805GPFD
board confirm 0/0

Aktualną konfigurację pokazuje:
#display current-configuration

Interfejsem do zarządzania (wyłącznie) jest meth, ustawiamy mu IP:
config
interface meth 0
ip address 172.16.20.1 255.255.255.0
save

Dodajemy VLAN:
config
vlan 300
port vlan 300 0/8 0 (300 to numer VLAN, 8 to karta GICF (zgodnie z display board 0), 0 to pierwszy port)
Możemy ustawić IP na VLANie:
interface vlanif301
ip address 10.10.20.2 255.255.255.0

Ustawiamy autofind na każdym porcie, na którym chcemy aby ONTy zostawały znajdowane:
interface gpon 0/0
port 0 ont-auto-find enable
port 1 ont-auto-find enable

Poniższą komendą można wylistować nieskonfigurowane nowe ONTy:
(config-if-gpon-0/0)#display ont autofind 0
Failure: The automatically found ONTs do not exist
(nie należy podpinać bezpośrednio ONT do OLT, bo sygnał będzie za mocny i ONT nie będzie widoczny, po podłączeniu jednego splittera 1×16 działa)

Dodajemy ONTa:
GAMS(config-if-gpon-0/0)#ont add 1 12 sn-auth „4857544306xxxxxx” omci ont-lineprofile-id 0 ont-srvprofile-id 1 desc „HG850aKK”
Number of ONTs that can be added: 1, success: 1
PortID :1, ONTID :12

GAMS(config-if-gpon-0/0)#display ont info 1 12
—————————————————————————–
F/S/P : 0/0/1
ONT-ID : 12
Control flag : active
Run state : online
Config state : normal
Match state : match
DBA type : SR
ONT distance(m) : 1554
ONT battery state : not support
Memory occupation : –
CPU occupation : –
Temperature : –
Authentic type : SN-auth
SN : 4857544306xxxxxx (HWTC-06D7E510)
Management mode : OMCI
Software work mode : normal
Isolation state : normal
ONT IP 0 address/mask : –
Description : HG850a BG112
Last down cause : –
Last up time : 2017-10-02 21:52:18+08:00
Last down time : –
Last dying gasp time : –
ONT online duration : 0 day(s), 0 hour(s), 0 minute(s), 20 second(s)
Type C support : Not support
Interoperability-mode : ITU-T
—————————————————————————–
VoIP configure method : Default
—————————————————————————–
Line profile ID : 0
Line profile name : line-profile_default_0
—————————————————————————–
FEC upstream switch :Disable
OMCC encrypt switch :Off
Qos mode :GEM-CAR
Mapping mode :VLAN
TR069 management :Disable
TR069 IP index :0
—————————————————————————–
Notes: * indicates Discrete TCONT(TCONT Unbound)
—————————————————————————–
DBA Profile-ID:2
DBA Profile-ID:20
—————————————————————————–
Service profile ID : 1
Service profile name : ont-default
—————————————————————————–
Port-type Port-number
—————————————————————————–
POTS 2
ETH 4
VDSL 0
TDM 0
MOCA 0
CATV 0
—————————————————————————–
TDM port type : E1
TDM service type : TDMoGem
MAC learning function switch : Enable
ONT transparent function switch : Disable
Ring check switch : Disable
Ring port auto-shutdown : Enable
Ring detect frequency : 8 (pps)
Ring resume interval : 300 (s)
Multicast forward mode : Unconcern
Multicast forward VLAN : –
Multicast mode : Unconcern
Upstream IGMP packet forward mode : Unconcern
Upstream IGMP packet forward VLAN : –
Upstream IGMP packet priority : –
Native VLAN option : Concern
Upstream PQ color policy : –
Downstream PQ color policy : –
—————————————————————————–
Port-type Port-ID QinQmode PriorityPolicy Inbound Outbound
—————————————————————————–
ETH 1 unconcern unconcern unconcern unconcern
ETH 2 unconcern unconcern unconcern unconcern
ETH 3 unconcern unconcern unconcern unconcern
ETH 4 unconcern unconcern unconcern unconcern
—————————————————————————–
Notes: * indicates the discretely configured traffic profile,
run the display traffic table ip command to query
traffic table configuration.
—————————————————————————–
Port-type Port-ID DownstreamMode MismatchPolicy
—————————————————————————–
ETH 1 operation discard
ETH 2 operation discard
ETH 3 operation discard
ETH 4 operation discard
—————————————————————————–
Port-type Port-ID Dscp-mapping-table-index
—————————————————————————–
ETH 1 0
ETH 2 0
ETH 3 0
ETH 4 0
IPHOST 1 0
—————————————————————————–
Port-type Port-ID IGMP-mode IGMP-VLAN IGMP-PRI Max-MAC-Count
—————————————————————————–
ETH 1 – – – Unlimited
ETH 2 – – – Unlimited
ETH 3 – – – Unlimited
ETH 4 – – – Unlimited
—————————————————————————–
Alarm policy profile ID : 0
Alarm policy profile name : alarm-policy_0
—————————————————————————–

Najprostsza jest konfiguracja ‚simplified’, tzn. bez ręcznego przydzielania gemportów:

service-port 1012 vlan 300 port 0/0/0 ont 12 iphost multi-service user-vlan 300 tag-transform translate
(do VLANu 300 na OLT, dodajemy końcówkę klienta (ONT) u niego też VLAN 300.
Zmiana hasła:
#terminal user password
User Name(<=15 chars):root Old Password(<=15 chars): New Password(length<8,15>):
Failure: The password must contain at least one digit
New Password(length<8,15>):
Confirm Password(length<8,15>):
Information takes effect
Repeat this operation? (y/n)[n]:n

DGS 1510 enable telnet

Switch(config)#line telnet
Switch(config-line)#password nowehaslo

Switch(config)#username admin password nowehaslo

Switch(config)#enable password nowehaslo

Switch(config)#ip telnet server

dla ssh podobnie:

Switch(config)#ip enable server

ale trzeba wygenerować klucz.

UBNT: Supervisory, Receiver not Ready

Nanostation LOCO M5 jako station, łączy się z AP, ale nie odpowiada na pingi, widać tcpdumpem:

11:19:16.086330 00:15:6d:e6:e4:XX > ff:ff:ff:ff:ff:ff Null Supervisory, Receiver not Ready, rcv seq 64, Flags [Poll], length 46
11:19:16.086346 00:15:6d:e6:e4:XX > ff:ff:ff:ff:ff:ff Null Unnumbered, xid, Flags [Response], length 46: 01 02

Pomaga restart zdalny.

Default IP/password/terminal speed

Ubiquiti 192.168.1.20, ubnt:ubnt

TP-Link SG3210, SG3216, SG3424
terminal speed 38400 8N1

TP-Link SG2424
default IP: 192.168.0.1
login: admin default password: admin
(brak RS232)

D-Link DGS-1510-20
terminal speed 115200 8N1
10.90.90.90

PHICOMM 302B/303 router
default IP: 192.168.2.1
login: admin password: admin

IBM storage DS3000
192.168.128.101 for the first controller.
192.168.128.102 for the second controller.

Pobór prądu przez różne urządzenia

Linksys SRW2048, 48portowy, pobiera 25W bez podłączonych portów, oraz +1W na każdy podniesiony port 1Gbps.

TP-Link SG3210, 8 portowy, pobiera 5.5W na luzie (sam zasilacz odłączony od switcha (12V) zużywa 2.4W) 6.2W po włożeniu SFP 3km SM WDM, oraz 9W przy podłączonych 8 portach miedzianych 1Gbps (bez SFP). Nie ma wentylatora.

TP-Link SG2424, 24 portowy, 4 porty wymienne z SFP. Zasilacz 5V. Pobiera 10.7W na luzie.
TP-Link SG3424, 24 portowy, 4 porty wymienne z SFP. Zasilacz 5V. Pobiera 8W na luzie.

netis ST3310GF (8 portów GE + 2 SFP) zasilacz 12V, pobór switcha na luzie 2.7W

Switch D-Link 1510-20 zasilanie 12V, pobór prądu 12W (bez wkładek i z LANami down), ma wentylator. Switch bootuje się 125 sekund(!)

Switch D-Link 1510-28X zasilacz 12V, pobór prądu 1A (pomiar za zasilaczem, na 12V, bez wkładek, na luzie, porty down). Ma jeden wentylator, z detekcją impulsów i czerwoną diodą gdy się zatrzyma. Switch bootuje się 135 sekund(!)

Raspberry PI+zasilacz mikrousb, 4.9W

Lampki choinkowe 300 LED 7.5W

wylaczony IBM x3650 pobiera 28W (podłączony jeden zasilacz)
procesor L5335 (Quad core), RAM 2*4GB, 2 hdd SATA 1TB 3.5″:
181W burnP6
191W 2*burn
198W 3*burn
207W 4*burn
na luzie linux: 173W

Serwer x3650, 2*Quad E5440 2.83GHz, 2*4GB RAM, dwa dyski 2.5″ 750GB, 2*Vertex SSD 256GB
8*burnP6 303W (tylko jeden podlaczony zasilacz)
na luzie, 189W (procesory przechodza na 1992MHz

Serwer x3650 E5345 2.33GHz, 2*4GB RAM, dwa dyski 2.5″ 500GB, 2*OCZ Vertex 128GB
175W na luzie, 231 cpuburnP6*4 (procki na 2.3 chodza caly czas)

Switch Cisco c3550 12G 87W (na luzie, bez wkładek)

Płyta ASROCK Q1900M (celeron J1900) z 8GB RAM DDR3L (1.35V) 21W (gdy się nudzi, z zasilaczem ‚jakiś od PC’)
ASROCK Q1900M+8GB+Intel Dual 10Gbps 31W (2*Direct Attach Copper) (przy 4*burnP6 37W)
(bez dysku, tylko karta SD, Debian)

STB w trakcie uśpienia:
MAG 250 3.4W
Zyxel czary 2101HD 4.5W
Zyxel biały 1001 7.9W
ADB 2840C 7W
EVIO M15 2.8W (podczas pracy 5W) (zasilacz 5V, bootuje się 62s)
Hybroad Z123 2W (podczas pracy 3W!) (zasilacz 12V, bootuje się 53s)

Huawei MA5683T w konfiguracjach:
1*SCUN, 1*PRTE 0.85A, 48V, 41W (mierzone na 48V); (73W mierzone na wejściu zasilacza Emerson HRS1150-9000)
2*SCUN, 1*PRTE 1.55A, 48V, 74W; (111W)
2*SCUN, 1*PRTE, 1*GICF (luzem) 1.55A, 48V, 74W; (113W)
2*SCUN, 1*PRTE, 2*GICF 1.60A, 48V, 77W; (116W)
2*SCUN, 1*PRTE, 2*GICF, 1*GPFD (16portów, bez wkładek) 2A, 48V, 96W; (135W)
2*SCUN, 1*PRTE, 1*GICF, 1*X2CS 1*GPFD (16portów, 6 wkładek C+) 2.1A*48V=100.8W;
(zasilacz bez podłączonego OLTa pobierał 10W)