Proxmox vnc

Aby dostać się przez dowolnego klienta VNC do konsoli należy nadanej VMce, w zakładce monitor wpisać:

# change vnc 0.0.0.0:100,password

# set_password vnc TAJNEHASLO

Wtedy vncserwer zaczyna słuchać na porcie 5900+100

Jak sprawdzić z jakiego akamai korzysta się?

mtr obrazki.elektroda.pl -c5 -r
HOST: host.amsnet.pl Loss% Snt Last Avg Best Wrst StDev
1.|– ns3.amsnet.pl 0.0% 5 0.2 0.5 0.1 0.9 0.4
2.|– pii.amsnet.pl 0.0% 5 0.4 0.4 0.3 0.5 0.1
3.|– 120.10.48.185.ip4.epix.ne 0.0% 5 3.0 3.2 3.0 3.7 0.3
4.|– akamai.plix.pl 0.0% 5 10.9 11.4 10.8 12.4 0.6
5.|– a23-59-85-138.deploy.stat 0.0% 5 10.4 10.6 10.0 11.5 0.6

windows10 rdesktop ERROR: CredSSP

Do windows 10 nie da się standardowo połączyć rdesktopem z linuksa:

$ rdesktop 172.16.34.99
Autoselected keyboard map pl
ERROR: CredSSP: Initialize failed, do you have correct kerberos tgt initialized ?
Connection established using SSL.

Trzeba wejść w Windows10->System->Panel sterowania->System->Ustawienia zdalne->Zdalny-> i tu wykasować haczyk z ‚Zezwalaj na połączenia tylko z komputerów, na których Pulpit zdalny jest uruchomiony z uwierzytelnianiem na poziomie sieci’

OLT Huawei – syslog i monit

OLT Huawei’a potrafi wysyłać logi poprzez syslog po UDP.

Aby włączyć zdalne słuchanie sysloga w Linuksie w rsyslog należy odremować linie w /etc/rsyslog.conf:
$ModLoad imudp
$UDPServerRun 514

Dobrze dodać aby log z OLT szedł do innego pliku, robi się to dodając do /etc/rsyslog.conf na początku reguł linie:

if $fromhost-ip startswith ‚10.11.x.’ then /var/log/olt.log
& ~

(gdzie 10.11.x to podsieć w której jest OLT. Ta druga linia oznacza, że ma już pozostałych reguł nie przechodzić, i nie zapisywać ponownie)

W OLT ustawiamy:
syslog enable alarm-event
loghost add 10.11.x.x log_server
loghost activate ip 10.11.x.x

gdzie 10.11.x.x to serwer rsyslogd

Teraz możemy skonfigurować monit, który będzie nas informował o problemach. W /etc/init.d/monitrc ustawiamy:

set mailserver localhost
set mail-format { from: [email protected]
subject: $SERVICE $EVENT at $DATE
message: Monit $ACTION $SERVICE at $DATE on $HOST: $DESCRIPTION.
Yours sincerely,
monita
check file olt.log with path /var/log/olt.log
if match „FAULT”
then alert
if match „RECOV”
then alert

Można bardziej szczegółowo ustawić informowanie, np.
if match „fiber is broken” lub „LOSi/LOBi” i będziemy dostawać emaile w przypadku prawdopodobnego ucięcia światłowodów do klientów, a o mniej istotnych informacjach nie.

Endomondo Xiaomi problem gps

Po wyłączeniu wyświetlacza GPS gubi sygnał, pojawia się dopiero po wybudzeniu.

Problem ustawienia oszczędzania baterii, należy:
Ustawienia->Bateria i wydajność->Zarządzaj użyciem baterii przez aplikacje->Wybierz aplikacje->Endomondo
->Bez ograniczeń
oraz
->Lokalizacja w tle -> Zezwól

Android – nie zasłaniaj pomarańczowego obszaru na ekranie

Telefon Xiaomi Redmi. Pojawiał się czesto napis ‚Nie zasłaniaj pomarańczowego obszaru na ekranie. Aby odblokować naciśnij głoścność+ oraz prawy dolny’.

Nie pomagała zmiana parametrów w menu. Pomogło – odcięcie nalepki ekranu z górnej części telefonu (na lewo i prawo od głościnka, pozostawiając na wyświetlaczu). Jest tam czujnik zbliżeniowy i naklejka przezroczysta powodowała, że telefon myślał, że jest w kieszeni!

mikrotik jako PIM router do telewizji (multicast)

/interface vlan
add interface=ether1 name=internet vlan-id=13
add interface=ether1 name=stb vlan-id=401
add interface=ether1 name=transmisja vlan-id=3700
/ip address
add address=192.168.x.50/29 interface=transmisja network=192.168.x.48
add address=172.16.5.2/24 interface=internet network=172.16.5.0
add address=10.1.1.1/24 interface=stb network=10.1.1.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall nat
add action=src-nat chain=srcnat out-interface=internet src-address=10.1.1.0/24 to-addresses=172.16.5.2
/ip route
add distance=1 gateway=172.16.5.1
add distance=1 dst-address=10.10.1.x/32 gateway=192.168.x.49
add distance=1 dst-address=10.100.y.0/24 gateway=192.168.x.49
add distance=1 dst-address=192.168.176.0/22 gateway=192.168.x.49
/routing pim
set switch-to-spt-interval=30s
/routing pim interface
add interface=stb
add interface=transmisja
/routing pim rp
add address=10.100.110.z

Nie konfiguruję dhcp, gdyż adresy rozdaje linux 10.1.1.2 w vlanie 401.

Dlaczego nie cisco? Docelowo tak będzie. Mikrotik bierze mniej prądu, na razie wystarcza.
Chciałem użyć do tego OLT Huawei MA5683T, ale wydaje się, że nie ma w nim PIM SM.

Przeniesienie klimatyzatora typu split

Aby przenieść klimatyzator typu split w inne miejsce trzeba rozłączyć rurki. Jest w nich czynnik roboczy, który wcześniej należy odpompować. Można to zrobić używając specjalnej butli oraz pompy próżniowej. Można też wykorzystać zbiornik w jednostce zewnętrznej i jej sprężarkę, zgodnie z poniższym opisem.

Procedura:
1. Zakręcić zawór na cienkiej rurze jednostki zewnętrznej
2. Włączyć chłodzenie
3. Gdy ciśnienie na manometrze spadnie do zera, zakręcić zawór grubej rury na jednostce zewnętrznej (proces trwa ok. 15-30 sekund, w zależności od długości przewodów klimatyzacyjnych. Poznać po tym, że klimatyzator przestaje chłodzić)

Po tym można rozłączyć rurki, przenieść klimatyzację w inne miejsce i podłączyć ponownie.

Uruchamianie Linuksa bez monitora

W nowszych systemach (prawdopodobnie tych z systemd) jeśli uruchomimy komputer bez monitora, a później go podłączymy, monitor nic nie wyświetla.

Sprawdzamy do jakiego wyjścia mamy podpięty monitor:

# for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n „${con#*/card?-}: „; cat $p; done
DP-1: disconnected
DP-2: disconnected
HDMI-A-1: connected
HDMI-A-2: disconnected
VGA-1: connected

Problem rozwiązuje dodanie w grub.cfg (gdzieś w linii linux=vmlinux) video=VGA-1:e

Najlepiej w /etc/default/grub dodać tak:
#GRUB_CMDLINE_LINUX_DEFAULT=””
GRUB_CMDLINE_LINUX=”video=VGA-1:e”

# update-grub
Generating grub configuration file …
Znaleziono obraz Linuksa: /boot/vmlinuz-3.16.0-4-amd64
Znaleziono obraz initrd: /boot/initrd.img-3.16.0-4-amd64
Adding boot menu entry for EFI firmware configuration
gotowe

(problem występuje np. na płycie Q1900M z J1900)